Contentful Images not loading in Facebook in-app Browser


If I share/click on a link to a page with Contentful images in Facebook Android app, which opens Facebook’s in-app browser, any images that are loaded from // are not displayed

I have been building my own blog using Contentful, and noticed it with my demo site. I looked for other sites using Contentful, and the same happens with them e.g., and

I have tried using non protocol-relative urls e.g., and the newer, but to no avail. Not sure what’s causing it. Also, the image in the Powered by Contentful attribution does not display in the FB in-app browser

I’m using the latest version of Facebook for Android

I’m not sure what else to try. Any ideas? Also, if someone else could confirm this is an issue, at least that would be a start too

Hi @briandev,
I have just tested this with the link you provided, and Facebook seemed to retrieve the image without any issues.

Would you have any other examples of that?

1 Like

Hi @gabriel

I have attached a screenshot from that link, opened in FB in-app Android browser
The smalltalk image should be loaded. It also happens with the the Contentful Blog - image attached below

Maybe it’s specific to Android FB App? I don’t have any other device to test it with at present

Hey Brian,

I’ve just tested on iOS, the only one available to me at the moment, and it worked without any issues:

I’m going to test on Android as possible and update you in case if it’s something specific to it.

Over the weekend I will be looking into the following topics to see if I can figure this out:

  • Facebook prefetching of Mobile Content
  • Affect of prefetching on images loaded from external sources
  • Affect of prefetching on images loaded from local assets folder
  • Options or possibility of disabling prefetching

I’m putting all my eggs in the ‘prefetching’ basket :slight_smile:

Hi @gabriel

Did you get a chance to test this on Android?

I’ve been reading up on Facebook link prefetching. It behaves differently on iOS and Android from what I’ve read, depending on FB app versions. There is a way to disable it, by creating an App ID, and adding it to the HTML of your site. It is something I will try if I cannot find a solution

Hi @briandev,

We did have a chance to test on Android and it also worked without any issues, which seems like a very specific problem. If you do have the chance, it would be great to try this in another device, and also perhaps try a different network connection from the one you’re currently using.

@briandev We are facing this same issue with one of our publisher page in Facebook. Have you been able to fix this issue?

Hi. No, I never found a solution. The fact it was happening with many sites, including the Content Blog page itself, made me think that the problem was tied to specific Android devices. It was a personal blog, so I didn’t delve much further into it