Contentful logo

Contentful Community

Contentful older versions documentation

#1

Hi there ,
I am having a struggle in using older versions of Contentful due to lack of documentation. I recently installed an older version of Contentful (2.4.1) . I made this choice to integrate Contentful in my Symfony 2.8 system . Can someone provide me this kind of documentation ?

Thank you ,
Kleidi

0 Likes

#2

Hello Kleidi,

sadly we are not offering support for older versions of the SDK. The version you are referring to seems to be older then a year, and also your Symfony version seems to not be officially supported by SensioLabs any more.

I would highly recommend you to update both versions to be something somewhat recent.

That said, maybe there is an easy fix, except for upgrading symfony and contentful. Could you explain your current problem just a bit more?

Thanks,
Mario

0 Likes

#3

Hello Mario ,

Thank you for your reply. I am currently trying to make a simple retrieve of content form Contentful , but of course the classes I want to use are not known to this version of Contentful. I am reading this simple getting started tutorial.

Can you suggest a different approach?
I repeat that I can’t update the version of Symfony due to the project size

Best,
Kleidi

0 Likes

#4

Hello Kleidi,

sadly I cannot help alot with such an old version. You could try and see if the source code repository from that release can help you: https://www.contentful.com/developers/docs/php/tutorials/getting-started-with-contentful-and-symfony/

Alternatively, you could post the error message and the code issueing this error, so maybe me or some community members can help with more detailed recommendations.

Greetings,
Mario

0 Likes