Contentful logo

Contentful Community

Zapier Address Integration

I’m using Zapier to add my content for various locations from a Google Sheet and ran into an issue.

So everything transfers over smoothly expect the Address field which causes an error. It seems as if the issue is coming from giving users the option of adding either an Address or Coordinates which isn’t allowing automatic input like the other fields do.

Just wondering if there is a solution or work around to this where a default is passed through.

Screenshot of the issue in Zapier

Hi @dominicgiangiobbe!

Could you please provide me details about your content model? I.e. what fields do you have and of what type?
And also what fields do you have in your Google Sheet?

I suspect making this information public may not be desired for you, thus, you can send these details to support@contentful.com and give a reference to this thread.

@andrey
The field in my content model is the standard Location field.

In my google sheet I’ve tried a couple different options(long, lat, street, city, state, zip) and none of them worked at all.

Below are all the different inputs for location I tried and none worked.
Also as you can see the Location Input (labeled as Address) isn’t connecting with Contentful unlike other fields with the logo being next to them.

@dominicgiangiobbe That’s interesting.

I think the problem could be that values are being send to different location method. I.e. Location field has 2 types of values: Coordinates and Address. Probably, the Zap trying to add Coordinates while default is Address.
2nd screenshot should be correct assuming Latitude and Longitude are column names from Google Sheet.
Am I right, that for all other fields it works fine and the problem is only with Location filed?

Hello everybody,

FYI: unfortunately, we’re not supporting the Zapier integration anymore. We’re sorry for the inconvenience.